Guida Rapida all’utilizzo di Microsoft Excel
Giorgio Delzanno

L’ambiente Excel

Excel ¢ un foglio elettronico costituito da tre diverse componenti: un gestore di cartelle di lavoro, un gestore di
database non relazionali (per elaborare liste di informazioni), e un generatore di grafici. Excel unisce capacita di
formattazione a capacita di calcolo e visualizzazione. Ritroveremo quindi nella componente di formattazione di Excel
vari aspetti di Word.

Strumenti

Per selezionare gli strumenti di lavoro utilizzare la voce Visualizza, Barre degli strumenti (View 2> Toolbar). Una
configurazione ragionevole prevede la visualizzazione della barra standard, la barra delle formule ed eventualmente la
barra di formattazione.
La Barra delle Formule mantiene informazioni sul contenuto della cella corrente, ed ¢ suddivisa in due parti:

1. Darea dei riferimenti posizionata a sx visualuzza 1’indirizzo della cella dove e’ posizionato il cursore

2. el’area di modifica posizionata a destra (vedi sezione Indirizzi ed Inserimento Dati e Funzioni).

Cartelle e Fogli di Lavoro

Excel permettere di creare, aprire e lavorare su diverse cartelle di lavoro.

Le cartelle di lavoro sono suddivise in fogli (solitamente tre al momento della creazione di una nuova cartella).

Ogni foglio puo essere considerato come un singolo documento, eventualmente suddiviso in pit pagine, sul quale si
opera a livello di singola cella. Un foglio viene visualizzato come una tabella suddivisa in righe e colonne. In realta in
fase di stampa verranno visualizzate solo le celle in cui sono stati inseriti dei dati.

Guida in linea, Gestione dei File, Ricerca, e Stampa

Simili alle operazioni viste in Word. In particolare, si noti che anche in Excel ¢ possibile selezionare cartelle pre-
formattate al momento della creazione di nuovi documenti (File> Nuovo (File > New)).

Per impostare 1’opzione di salvataggio con copie di back-up: File>Salva con Nome—> Opzioni (File > Save
as>Options);

Per impostare I’opzione di salvataggio automatico Strumenti—> Salvataggio automatico (Tools—>Save). Se la voce
non ¢ presente sotto Strumenti (Tools) si puo aggiungere utilizzando Strumenti-> Aggiunte (Tools > Customize).

Impostazione pagina e fogli

Come nel caso di Word ¢ possibile impostare le caratteristiche delle pagine dei nostri fogli di lavoro (margini,
intestazioni, ecc) utilizzano le voci File> Imposta Pagina (File->PageSetup) ¢ Visualizza-> Intestazione e Pié
Pagina (View > Header and Footer).

(Nota: si possono anche inserire Note, Riferimenti incrociati, ecc.).

Formattazione dei Fogli

Ogni foglio viene automaticamente suddiviso in pagine, formattate a loro volta a seconda dei parametri specificati

nell’impostazione della pagina.

Tuttavia

e se la larghezza impostata ¢ minore della larghezza dell’area del foglio effettivamente utilizzata (numero di celle
non vuote), in stampa il foglio stesso verra suddiviso verticalmente su piu pagine;

e sipuo forzare la suddivisione in pagine, ad esempio selezionando una riga (interruzione orizzontale) o una colonna
(verticale) ed inserendo un’interruzione di pagina (voce Inserisci = Interruzione di pagina (Insert 2 Break) )
come per le sezioni dei documenti Word.

Visualizzazione

Per evidenziare le interruzioni di pagine si puo utilizzare la voce Visualizza-> Anteprima interruzioni di pagina
(View—>Print Preview).
Come in Word si puo visualizzare il risultato dell’elaborazione utilizzando File, Anteprima Stampa.



Gestione dei Fogli (Worksheets)

Celle, indirizzi e riferimenti

Excel visualizza ogni foglio suddividendolo in celle. Si puo operare su un foglio a vari livelli di granuralita: celle, righe,
colonne, intervalli di celle, intervalli di fogli. Ognuna di queste entita puo essere individuata tramite indirizzi e
riferimenti.
e  Per default i fogli assumo i nomi Fogliol, Foglio2, ecc.; i nomi si possono personalizzare tramite la voce
Formato—> Foglio> Rinomina (Format - Sheet > Rename).
e Le Colonne(Columns) sono identificate da lettere: A, B, C,... (come mostrato dalla barra superiore di ogni foglio);
e Le Righe (Rows) sono identificate da numeri: 1,2,3,... (come mostrato nella barra laterale dei fogli);
o L’indirizzo delle celle (cell) ¢ determinato dal nome del foglio, colonna e riga sul quale si trovano.
Il formato degli indirizzi ¢: Foglio!ColonnaRiga (es. Sheetl!Al).
Se si omette il nome del foglio, si assume implicitamente di lavorare in quello corrente.
o Un intervallo di celle viene identificato dal riferimento IndirizzoPrimaCella:IndirizzoUltimaCella
(ad es. A1:B2 identifica 4 celle);
e L’intervallo che consiste si tutte le celle di una riga (colonna) viene indicato con il riferimento Riga:Riga
(Colonna:Colonna); ad esempio, 5:5 identifica tutte le celle (non vuote) della quinta riga.
e Un intervallo di fogli viene identificato dal riferimento NomePrimoFoglio:NomeUltimoFoglio

Inserimento di Dati

I dati vengono inserito sempre nella cella correntemente selezionata (visualizzata con un contorno in rilievo).
Tramite il mouse ¢ possibile selezionare le celle del foglio corrente (e quindi navigare nel foglio).

La barra delle formule mantiene le informazioni associate alla cella corrente:

e [indirizzo della cella corrente nell’area dei riferimenti

e il suo contenuto nell’area di modifica.

I dati possono essere inseriti scrivendo nella cella corrente, oppure nell’area di modifica.

Per confermare I’avvenuto inserimento dei dati basta premere Enter o selezionare un’altra cella con il mouse.

I dati festuali vengono inseriti nella cella senza mai andare a capo. Se le celle seguenti non sono vuote il testo verra
troncato a meno di modifiche alla larghezza della cella. In alternativa, si puo selezionare 1’opzione Formato—>
Celle> Allineamento—>Testo a Capo (Format = Cells=> Alignment ->Wrap text) per scrivere il testo su piu righe.
Per inserire i dati di un intervallo in modo rapido, occorre prima selezionare 1’intervallo ¢ quindi inserire i dati delle
celle e premere il tasto Enter (senza bisogno di spostare il mouse).

Si possono assegnare nomi simbolici alle celle (da utilizzare come riferimenti) attraverso 1’area dei riferimenti.
Inoltre ¢ possibile associare commenti (ad es. descrizione dettagliata del contenuto o della formula) a singole celle
utilizzando Inserisci=> Commento (Insert 2> Comment). Le celle commentate sono visualizzate con un triangolo
rosso in alto a destra.

Inserimento di Serie di Dati

Excel permette di inserire velocemente serie di dati quali: sequenza di numeri crescenti, sequenza dei mesi a partire da
uno di essi, ecc. Per visualizzare il tipo di serie andare alla voce Tools = Options = Custom lists. Tramite la stessa
opzione si possono inserire nuove serie di dati.

Per inserire la serie dei dati nel foglio di lavoro, dopo aver inserito il valore iniziale, basta premere il quadrato in basso a
destra (chiamato fill handle) nella cornice della cella e trascinarlo lungo la riga, colonna, o range desiderato.

Se durante il trascinamento si tiene premuto il tasto CTRL oppure se il punto iniziale non corrisponde ad alcuna serie
predefinita (o definita dall’utente), la precedente operazione (trascinamento del quadratino fill handle) copia
semplicemente il testo nella parte di foglio desiderata.

Per definire una serie di numeri si puo inoltre:

e inserire i primi due numeri della serie, selezionare le due celle corrispondenti, e trascinare il fill handle per
costruire una serie che cresce a seconda dell’intervallo tra i due numeri.
Ad es. Selezionando le celle 1 e 4 e trascinando il fill handle a destra otteniamo la sequenza
1 4 7 10

e inserire il primo numero della serie, selezionare la cella e tramite 1’opzione Edit 2 Fill > Series inserire
una serie che cresce in modo lineare (Linear) od esponenziale (Growth): Step ¢ Stop determinano



rispettivamente il coefficiente di crescita: y=Step*x+v, nel caso lineare e y= vo*Step” nel caso esponenziale;
x corrisponde al numero d’ordine delle celle (0,1,2,3, ecc), vy ¢ il valore iniziale e y ¢ il valore calcolato per
ogni cella della serie.

Ad esempio: Selezionando Growth, Step=2, Stop=200, a partiredalla cella 5 otteniamo la sequenza:
5 10(=5%2" 20(=5%2%) 40(=5*2) 80 160

Inserimento Funzioni
Oltre a stringhe e numeri ¢ possibile associare espressioni alla cella corrente.

Le espressioni iniziano sempre con il simbolo = e possono contenere sia valori (ad es. 10 oppure 3.14) che riferimenti

(ad es. A1, oppure Foglio2!A3, oppure A1:A5 (vedi Sezione su Celle. Indirizzi e Riferimenti) ¢ possono essere

costruite utilizzando

e isimboli aritmetici

e isimboli logici e I’operatore se-condizione allora-espressionel altrimenti espressione2

o le funzioni predefinite presentate in Inserisci> Funzione (Insert - Function) che operano su intervalli

Per inserire velocemente un’espressione, si possono utilizzare

e [l’area di modifica premendo il tasto = oppure inserendo la formula (ad es. =A7+B7-1)

e i tasti sulla barra standard (che indicano somma )’ e funzioni fx) e poi selezionare le caselle da inserire nelle
formule (la barra di modifica mostrera i riferimenti aggiunti alla formula).

Premere Enter per confermare 1’inserimento della formula.

Nota: dopo aver inserito la funziona il foglio visualizzera direttamente il risultato (corrente) della sua valutazione.

Precedenza degli operatori
La formula 3*6+12/4-2 si valuta in 19 (* e / hanno la precedenza su + e -).
Si puo forzare un ordine di valutazioni usando (come al solito) le parentesi: 3*(4+12)/4 si valua in 12

Esempi di funzioni

Somma dei valori delle celle Al e B4 del foglio corrente: A1+B4 oppure SOMMA (A1;B4)

Somma dei valori di celle di un intervallo A1-A2: SOMMA(A1:A2)

Somma dei valori nella colonna A: SOMMA(A:A)

Somma del valore di una cella dal foglio corrente e di una cella dal foglio F2: SOMMA(A3;F2!A2)
Somma del valore della cella A1 nell’intervallo di fogli F1-F2: SOMMA(F1-F2!A1)

Modifiche ad una Cartella di Lavoro (Editing a Worksheet)

Aggiungere ed eliminare Fogli, Righe, Colonne, Celle
Si utilizzano le voci Inserisci > Celle, Righe, Colonne, Fogli (Insert) ¢ Modifica—> Elimina (Edit > Delete).

Nota: l'inserimento di una cella provoca lo spostamento delle altre celle nella stessa riga o colonna, le righe e colonne
vengono inserite prima della riga correntemente selezionata.

Copiare e Spostare Celle e Range

Per copiare il contenuto di celle e range si puo utilizzare la voce Modifica—> Copia/Incolla (Edit > Cut/Paste) oppure
la selezione con il mouse e il trascinamento come in Word (premendo CTRL si copia invece di spostare).

Quando si copiano o si spostano formule con indirizzi relativi (cio¢ i riferimenti usuali), gli indirizzi vengono
modificati a seconda della posizione di arrivo.

Per evitare modifiche degli indirizzi quando si copia una cella contenente un’espressione, occore utilizzare gli indirizzi
assoluti, i.e., aggiungere $ prima di un indirizzo di riga, e/o colonna (ad es. $A$1 verra copiato immutato, mentre in
$A1 verra modificato solo il numero di riga).

L’inserimento di funzioni introduce delle dipendenze funzionali tra le celle di una cartella. Per visualizzare tali
dipendenze ¢ possibile utilizzare la voce Strumenti=>Controllo (Tools=> Auditing > Trace Dependents/Precedents).

Formattazione di celle (Cell Formatting)

La dimensione delle celle puo essere modificata allargando le righe e le colonne selezionando la riga di separazione
nella cornice dell’intestazione di righe e colonne oppure attraverso la voce Formato—> Righe/Colonne
(Format->Rows/Colums).



Un doppio click sulla riga di separazione adatta la larghezza al valore che occupa piu spazio nella riga (colonna)
corrispondente.

Inoltre, il testo e il layout di celle e range possono essere formattati utilizzando (come in word) la barra di formattazione
dove si trovano nuove funzionalita quali il tipo di valori inserito (es. lire, percentuali, ecc.) e la voce Formato—> Celle
(Format > Cells).dove ¢ possibile specificare ad. es. I’orentazione del testo ecc.

Come in word si possono formattare parole, parti di testo, celle, o range utilizzando in modo opportuno la selezione
tramite il mouse.

Formattazione condizionale (Conditional Formatting)

Excel permette di definire formattazioni che dipendono dal valore corrente di una cella (ad es. se il valore della cella ¢
minore di zero, allora scrivo la cifra in rosso) o dal valore di una funzione logica (cio¢ che restituisce VERO o FALSO)
definita su valori o riferimenti (ad es. se A1 > A2 allora scrivi la cifra della cella corrente in rosso). La voce Formato—>
Formattazione Condizionale (Format > Conditional Formatting) permette di inserire le condizioni e il relativo
formato.

Riferimenti circolari e calcolo iterativo delle foglio di lavoro

Le formule inserite nelle celle di una tabella Excel si possono interpretatere come assegnamenti in un linguaggio di
programmazione. Ad es. la formula =B1+B2 nella cella A1 rappresenta I’assegnamento A1=B1+B2.

Solitamente il calcolo di tale formule viene fatto automaticamente dopo ogni aggiornamento del contenuto delle
Celle. Il calcolo puo essere tuttavia controllato dall’utente tramite le opzioni Tools=> Option = Calculation.

In particolare ¢ interessante vedere come funziona e a cosa serve la modalita di lavoro che permette di fare calcoli
iterativi. Per questo motivo dobbiamo introdurre la nozione di riferimento circolare.

Quando la dipendenza tra le celle che occorrono in una serie di tabelle forma una relazione ciclica si € in presenza di
riferimenti circolari (Circular References). Ad es. A1=B1 e B1I=A1+1.

In molti casi i riferimenti circolari rappresentano un errore nell’impostazione della tabella.

Tuttavia esistono situazioni in cui puo essere interessante impostare formule con riferimenti circolari e cercare di
calcolare una soluzione iterando il calcolo a partire da determinati valori iniziali per le celle coinvolte nelle formule.
Notiamo infatti che in un linguaggio di programmazione 1’assegnamento A1=A1+1 permette di incrementare il vecchio
valore di Al di un’unita assegnata nuovamente ad A1l. Se partiamo dal valore A1=0 e iteriamo il calcolo 10 volte
otterremo alla fine il valore A1=10.

Questo tipo di comportamento (iterazione per riferimenti circolari) si puo ottenere selezionando il metodo di calcolo
iterativo per la nostra tabella tramite I’opzione Tools = Options = Calculation, opzione Iteration, con numero
massimo di passi di iterazione (Maximal iterations) e soglia che rappresenta la differenza tra i risultati di due passi
consecutivi al di sotto della quale I’iterazione si ferma (Maximal Change).

Ad es. le formule A1=A1+B1 e B1=20 con 10 passi di iterazione danno origine al seguente frammento di programma:

Iterations := 10;
B1:=20;
Al :=0;
while (Iterations > 0) do
Al := Al1+B1
Iterations := Iterations-1;
endw.

Macro e registrazione macro

Per memorizzare una serie di operazioni effettuate su un foglio di calcolo € possibile utilizzare il comando Tool 2>
Macro = Record Macro. Dopo aver associato un nome alla macro ed eseguito una serie di operazione (ad es.
Inserimento dati, cancellazione, ecc) bisogna premere il tasto Stop in modo che la sequenza di operazioni sia associata
alla cella inizialmente selezionata.

Liste come database

Le tabelle Excel possono essere utilizzate anche come tabelle di un database relazionale.

Le colonne rappresentano gli attributi della tabella, le righe rappresentano i record (i valori degli
attributi). I dati inseriti nella tabella possono essere analizzati utilizzando i filtri e i criteri.

Per costruire una tabella occorre innanzitutto definire le etichette (label) delle colonne utilizzando
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I’opzione Insert > Name > Label. L’analisi dei dati si effettua utilizzando una serie di celle che contegono

i criteri poste al di sopra della tabella (almeno una riga vuota tra criteri e label).

I criteri consistono di etichette sulle quali si vuole definire un filtro e su righe sottostanti criteri di selezione basati su
Valori ed operazioni di confronto.

Ecco un esempio:

Materia |Scritto  Orale +ﬁ criteri
>25 >25
label
\Materia Scritto Orale Totale 1-‘\
Fisica 20 26 23 label
Analisi 30 30 30
Chimica 28 24 26 .
dati
\Materia Scritto Orale Totale |
Analisi 30 30 30 &——
risultato
analisi

I criteri possono essere utilizzati per impostare dei filtri (cio¢ per estrarre dei dati dalla tabella).

Per questa operazione si puo utilizzare 1’opzione Data > Filters > Advanced Filters.

Nella finestra di dialogo occorre inserire 1’intervallo dei dati da analizzare, I’intervallo che identifica

I criteri (label incluse) e I’intervallo in cui mostrare il risultato dell’analisi (nell’esempio i nomi delle materie
con voto medio scritto e orale sauperiore al 25).

Le etichette all’interno di un criterio denotano gli attributi per i quali si sta definendo il filtro (cio¢ gli attributi che
si vogliono estrarre dalla tabella).

I criteri posti sulla stessa riga denotano la congiunzione delle condizioni (ad es. Scritto>25 e Orale >25)

I criteri posti su righe diverse denotano la disgiunzione delle condizioni:

Materia |Scritto Orale
>25 >25

Materia |Scritto Orale |

>25 disgiunzione

congiunzione
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